Do you support “TLS 1.2” and “TLS 1.3” for PayPal, AuthorizeNet, and other services?

If you use scripts on your site that securely connect to third-party servers, such as those run by PayPal or the AuthorizeNet credit card company, the other company may send you a notice saying they’re upgrading their security systems, and that they need you to check that your script and hosting company supports “TLS 1.2” or “TLS 1.3”

Our servers do fully support TLS 1.2 and 1.3. All you need to do is make sure that your script (which could be in the form of a WordPress plugin or something similar) is current and also supports TLS 1.2 or 1.3.

If you’re using a script that has been updated within the last year, it almost certainly will support it. If you’re using an older script, the company that provided the script or plugin can confirm this.

TLS 1.2 and the “Seamless Donations” WordPress plugin

A WordPress plugin called Seamless Donations sometimes shows this message:

WARNING: Your server appears to have incompatibilities with PayPal's requirements cURL: 7.26.0, SSL: OpenSSL/1.0.1t

cURL version too low: PayPal requires TLSv1.2, which requires cURL 7.34.0 or greater. Your server appears to be running an older version.

This error message is incorrect due to a bug in the plugin, and you can safely ignore it. Our version of cURL properly supports TLS 1.2.